Baza losowań
Baza losowań jest bazą danych zawierającą wyniki losowań dla danej gry. Na podstawie bazy losowań generowane są wszystkie statystyki i typowania. Podobnie jak statystyki, baza losowań może być bardzo pomocna w typowaniu liczb do systemów. Aby zobaczyć losowania dla wybranej gry:
Wybierz z menu Narzędzia pozycję Baza losowań
Kliknij na pasku operacji przycisk Losowania
Losowania pokazane są w tabeli (zakładka Losowania). Tabela zawiera następujące kolumny:
Nr - numer (indeks) losowania, ostatnie losowanie (najnowsze) ma największy indeks
Data - data losowania
Dzień - skrót dnia tygodnia w którym odbyło się losowanie
Liczby - wylosowane liczby.
Pod tabelą losowań znajduje się ramka Pokaż losowania. Zawiera ona trzy opcje. Jeśli żaden filtr nie jest ustawiony w bazie, wtedy te trzy opcje są zablokowane. Opis opcji jest następujący:
Wszystkie - powoduje pokazanie w tabeli losowań wszystkich losowań z danego okresu czasu. Losowania zgodne z warunkami filtru lub zgodne z warunkami filtru kombinacja będą wyróżnione
Po filtracji - powoduje pokazanie tych losowań, które są wynikiem zastosowania na bazie wybranych filtrów
Po filtrze kombinacja - powoduje pokazanie tych losowań, które są wynikiem zastosowania na bazie filtru kombinacja, czyli pokazane zostaną tylko te losowania, które zawierają wybraną kombinację
Na zakładce Filtr znajduje się tabela filtr, która zawiera informację o ustawionym w bazie filtrze – nazwa filtru i jego dokładny opis. Poniżej tabeli znajduje się przycisk Usuń filtry. Jego naciśnięcie powoduje usunięcie filtrów z bazy.
Zakres losowań
Baza losowań posiada jeden parametr: Zakres losowań. W tabeli losowania pokazane są te losowania, których data zawiera się w wybranym okresie czasu. Aby ustawić zakres losowań w bazie:
Wybierz z menu Parametry pozycję Zakres losowań
Kliknij na pasku operacji przycisk Zakres
Wybierz z menu kontekstowego Zakres losowań
Modyfikacja bazy
Aby dodać, zmienić lub usunąć losowanie:
Wybierz z menu Zadania pozycję Dodaj, Zmień lub Usuń
Kliknij na pasku operacji przycisk Dodaj, Zmień lub Usuń
Wybierz z menu kontekstowego pozycję Dodaj, Zmień lub Usuń
Po wyborze operacji Dodaj lub Zmień pokaże się okno dialogowe do edycji losowania. Datę losowania ustawiamy w polu Data losowania. Wybór liczb losowania jest podobny do operacji wyboru klucza dla systemu.
Uwaga: Aby zapisać zmiany w bazie kliknij przycisk Zapisz.
Wyszukiwanie liczb
Baza posiada możliwość wyszukiwania określonej kombinacji. Wyszukiwanie można przeprowadzić na 2 sposoby:
Znajdź kombinację - losowanie zawierające poszukiwaną kombinację zostanie zaznaczone w tabeli losowań. Aby wybrać kombinację kliknij przycisk Znajdź kombinację. Pokaże się okno dialogowe do ustawiania parametrów wyszukiwania. Poszukiwaną kombinację można wpisać ręcznie w polu kombinacja lub wybrać ją klikając przycisk Wybierz. W ramce Liczba wspólnych liczb określamy, czy dane losowanie ma zawierać wszystkie liczby wybranej kombinacji (opcja wszystkie) czy też tylko kilka z nich (opcja określona). W przypadku wyboru drugiej opcji należy wpisać odpowiednią wartość w polu Ilość liczb. W ramce Kierunek określamy czy podczas wyszukiwania będziemy posuwali się w górę lub dół tabeli losowań. Po zatwierdzeniu parametrów, w tabeli wyników zostanie zaznaczone pierwsze pasujące losowanie. Aby znaleźć kolejne losowanie kliknij przycisk Znajdź następną lub naciśnij klawisz F3
Filtr kombinacja - w tabeli losowań pokazane zostaną tylko te losowania, które zawierają wybraną kombinację. Aby wybrać kombinację należy kliknąć przycisk Filtr kombinacja. Pokaże się okno dialogowe do wyboru kombinacji. Wybór liczb jest podobny do operacji wyboru klucza dla systemu. Po wyborze kombinacji w ramce Pokaż losowania zostanie zaznaczona opcja Po filtrze kombinacja. Aby usunąć filtr i wrócić do normalnego widoku kliknij przycisk Usuń filtr kombinacja
Filtrowanie
Bazę losowań, podobnie jak system, możemy poddać filtracji w następujący sposób.
Wybierz z menu Narzędzia pozycję Filtr
Kliknij na pasku operacji przycisk Filtr
Wybierz z menu kontekstowego pozycję Filtruj losowania
Po zatwierdzeniu filtru w tabeli pokazane zostaną losowania zgodne z warunkami filtru. W ramce Pokaż losowania zostanie zaznaczona opcja Po filtracji.
Aktualizacja bazy
Aby zaktualizować bazę poprzez sieć Internet:
Z menu Narzędzia wybierz pozycję Aktualizacja bazy losowań
Kliknij przycisk Import z sieci
Wybierz z menu kontekstowego pozycję Import z sieci
Pokaże się okno - Aktualizacji bazy losowań.
Import losowań z edytora tekstu
Aby dodać kilka losowań z edytora tekstu:
Kliknij przycisk Import z edytora
Wybierz z menu kontekstowego pozycję Dodaj kilka losowań
W oknie dialogowym, na zakładce Parametry definiujemy następujące parametry:
Format linii - format linii z edytora zawierającego losowanie. Sposób ustawiania parametrów formatu linii znajdziesz tutaj
Sposób aktualizacji - określa jakie losowania zostaną zapisane do bazy. Opcja Dodaj wszystkie losowania oznacza, że do bazy zostaną dodane wszystkie losowania wpisane w edytorze. Opcja Dodaj tylko nowe losowania oznacza, że do bazy dodane zostaną tylko nowe losowania, tzn. losowania których daty będą większe od najnowszego losowania w bazie.
Na zakładce Edytor znajduje się edytor tekstu w którym wpisujemy losowania. Aby sprawdzić ile losowań zostanie zapisanych do bazy przy dantych ustawieniach parametrów, naciśnij przycisk Sprawdź. Liczba losowań zostanie pokazana w polu Liczba dodanych losowań. Naciśnięcie przycisku OK spowoduje dodanie losowań wpisanych w edytorze do bazy losowań.
Import losowań z pliku
Aby zaimportować losowania z pliku tekstowego:
Kliknij przycisk Import z pliku
Wybierz z menu kontekstowego pozycję Import z pliku
Pokaże się okno dialogowe do wyboru pliku i ustawiania parametrów importu. W ramce Format linii określamy format linii z pliku tekstowego zawierającego losowanie. Sposób ustawiania parametrów formatu linii oraz znaczenie parametru Od losowania znajdziesz tutaj. Aby wybrać plik z którego pobrane zostaną losowania kliknij przycisk Wybierz. Pokaże się okno dialogowe do wyboru plików. Aby sprawdzić ile losowań można pobrać z pliku przy danych ustawieniach parametrów, naciśnij przycisk Sprawdź. Liczba losowań zostanie pokazana w polu Liczba losowań. Naciśnięcie przycisku OK spowoduje zapisanie zaimportowanych losowań do bazy losowań.
Export losowań z pliku
Aby zapisać widoczne losowania do pliku tekstowego:
Kliknij przycisk Export do pliku
Wybierz z menu kontekstowego pozycję Export do pliku
Pokaże się okno dialogowe w którym wpisujemy nazwę dla pliku.
Generacja losowań
Można wygenerować określona liczbę losowań za pomocą generatora liczb o rozkładzie jednostajnym (tzn. prawdopodobieństwo wylosowania każdej liczby jest takie samo). Aby wygenerować losowania:
Naciśnij przycisk Generuj losowania
Wybierz z menu kontekstowego pozycję Generuj losowania
Pokaże się okno dialogowe w którym należy wpisać datę początkową (datę pierwszego losowania) oraz liczbę losowań do wygenerowania. Tak utworzone losowania można zapisać a następnie analizować, tak samo jak w przypadku rzeczywistych losowań. Dzięki temu można sprawdzić czy wyniki statystyk na danych rzeczywistych różnią się znacznie od wyników na danych generowanych.
Raport bazy
Aby wysłać widoczne losowania do programu Microsoft Excel:
Wybierz z menu Plik pozycję Raport
Wybierz z menu kontekstowego Raport
Zobacz także:
Zakres losowań | Parametry gry i programu | Aktualizacja bazy losowań | Filtr | Filtr kombinacja | Klucz systemu